gpo.zugaina.org

Search Portage & Overlays:

dev-python/PyQt5-python2

Python bindings for the Qt framework

Screenshots

  • PyQt5-python2-5.14.2-r2
    amd64 arm arm64 ~ppc ~ppc64 x86
    bluetooth dbus debug declarative designer examples gles2-only gui help location multimedia network networkauth opengl positioning printsupport sensors serialport sql +ssl svg testlib webchannel webkit websockets widgets x11extras xmlpatterns python_targets_python2_7

    View      Download      Browse     License: GPL-3   
    Overlay: calculate (layman)

Runtime Dependencies

PyQt5-python2-5.14.2-r2

!dev-python/PyQt5[python_targets_python2_7]

python_targets_python2_7?
      ( >=dev-lang/python-2.7.5-r2:2.7 )


>=dev-lang/python-exec-2:=[python_targets_python2_7
      (-)
?
,-python_single_target_python2_7
      (-)
]
python_targets_python2_7?
      ( dev-python/enum34[python_targets_python2_7
            (-)
      ?
,-python_single_target_python2_7
            (-)
      ] )

>=dev-python/PyQt5-sip-python2-4.19.20:=
>=dev-qt/qtcore-5.12:5
>=dev-qt/qtxml-5.12:5

bluetooth?
      ( >=dev-qt/qtbluetooth-5.12:5 )

dbus?
      ( dev-python/dbus-python2[python_targets_python2_7] >=dev-qt/qtdbus-5.12:5 )

declarative?
      ( >=dev-qt/qtdeclarative-5.12:5[widgets?
] )

designer?
      ( >=dev-qt/designer-5.12:5 )

gui?
      ( >=dev-qt/qtgui-5.12:5[gles2-only=] )

help?
      ( >=dev-qt/qthelp-5.12:5 )

location?
      ( >=dev-qt/qtlocation-5.12:5 )

multimedia?
      ( >=dev-qt/qtmultimedia-5.12:5[widgets?
] )

network?
      ( >=dev-qt/qtnetwork-5.12:5[ssl=] )

networkauth?
      ( >=dev-qt/qtnetworkauth-5.12:5 )

opengl?
      ( >=dev-qt/qtopengl-5.12:5 )

positioning?
      ( >=dev-qt/qtpositioning-5.12:5 )

printsupport?
      ( >=dev-qt/qtprintsupport-5.12:5 )

sensors?
      ( >=dev-qt/qtsensors-5.12:5 )

serialport?
      ( >=dev-qt/qtserialport-5.12:5 )

sql?
      ( >=dev-qt/qtsql-5.12:5 )

svg?
      ( >=dev-qt/qtsvg-5.12:5 )

testlib?
      ( >=dev-qt/qttest-5.12:5 )

webchannel?
      ( >=dev-qt/qtwebchannel-5.12:5 )

webkit?
      ( dev-qt/qtwebkit:5[printsupport] )

websockets?
      ( >=dev-qt/qtwebsockets-5.12:5 )

widgets?
      ( >=dev-qt/qtwidgets-5.12:5 )

x11extras?
      ( >=dev-qt/qtx11extras-5.12:5 )

xmlpatterns?
      ( >=dev-qt/qtxmlpatterns-5.12:5 )