gpo.zugaina.org

Search Portage & Overlays:

dev-python/spyder

The Scientific Python Development Environment

Screenshots

  • spyder-4.1.4
    ~amd64 ~x86
    test doc python_targets_python3_7 test

    View      Download      Browse     License: MIT   
    Overlay: gentoo (distro)
  • spyder-4.1.3
    ~amd64 ~x86
    test doc python_targets_python3_7 test

    View      Download      Browse     License: MIT   
    Overlay: gentoo (distro)
  • spyder-3.2.7
    ~amd64 ~x86
    doc hdf5 python_targets_python2_7 python_targets_python3_4 python_targets_python3_5 python_targets_python3_6

    View      Download      Browse     License: MIT   
    Overlay: gamarouns (layman)
  • spyder-2.3.3-r1000
    *
    doc ipython matplotlib numpy pep8 psutil +pyflakes pylint +rope scipy sphinx python_abis_2.7 python_abis_3.4 python_abis_3.5 python_abis_3.6 python_abis_3.7

    View      Download      Browse     License: MIT   
    Overlay: progress (layman)

USE Flags

test
Global: Workaround to pull in packages needed to run with FEATURES=test. Portage-2.1.2 handles this internally, so don't set it in make.conf/package.use anymore
doc
Global: Adds extra documentation (API, Javadoc, etc)
python_targets_python3_7
* This flag is undocumented *
hdf5
Global: Adds support for the Hierarchical Data Format v5
python_targets_python2_7
* This flag is undocumented *
python_targets_python3_4
* This flag is undocumented *
python_targets_python3_5
* This flag is undocumented *
python_targets_python3_6
* This flag is undocumented *
ipython
Global: Add support for dev-python/ipython
matplotlib
Global: Add support for dev-python/matplotlib
Local: Add support for dev-python/matplotlib
numpy
Global: Add support for dev-python/numpy
Local: Add support for dev-python/numpy
pep8
* This flag is undocumented *
psutil
* This flag is undocumented *
+pyflakes
* This flag is undocumented *
pylint
Global: Add support for dev-python/pylint
Local: Add support for dev-python/pylint
+rope
* This flag is undocumented *
scipy
Global: Add support for sci-libs/scipy
Local: Add support for sci-libs/scipy
sphinx
* This flag is undocumented *
python_abis_2.7
* This flag is undocumented *
python_abis_3.4
* This flag is undocumented *
python_abis_3.5
* This flag is undocumented *
python_abis_3.6
* This flag is undocumented *
python_abis_3.7
* This flag is undocumented *