gpo.zugaina.org

Search Portage & Overlays:

www-plugins/browserpass

WebExtension host binary for pass, a UNIX password manager

Screenshots

ChangeLog

# ChangeLog for www-plugins/browserpass
# Copyright 1999-2019 Gentoo Authors; Distributed under the GPL v2
# (auto-generated from git log)

11 Dec 2019; wjn <wjn@aol.jp> -browserpass-3.0.6.ebuild:
Delete old version 3.0.6

*browserpass-3.0.6-r1 (11 Dec 2019)

11 Dec 2019; wjn <wjn@aol.jp> +browserpass-3.0.6-r1.ebuild:
Add version 3.0.6-r1

Gentoo repository's package goes to include depended Go modules
This commit follows that

13 Apr 2019; wjn <wjn@aol.jp> -browserpass-2.0.21.ebuild,
-browserpass-3.0.4.ebuild:
Delete old version 2.0.21 and 3.0.4

*browserpass-3.0.6 (13 Apr 2019)

13 Apr 2019; wjn <wjn@aol.jp> +browserpass-3.0.6.ebuild:
Add version 3.0.6

*browserpass-3.0.4 (08 Apr 2019)

08 Apr 2019; wjn <wjn@aol.jp> +browserpass-3.0.4.ebuild:
Add version 3.0.4

This is an Upstream's pre-release version
https://github.com/browserpass/browserpass-native/releases/tag/3.0.4

Browserpass version 3.0.0 and later have no backward compatibility
Version 3.0.0 or later of Browserpass add-on/extension must be installed
https://github.com/browserpass/browserpass-extension

Dependencies:
>=www-plugins/browserpass-3
- dev-go/go-sys ( golang.org/x/sys )
*also needed by dev-go/logrus
- dev-go/lfshook ( github.com/rifflock/lfshook )
- dev-go/logrus ( github.com/sirupsen/logrus )
*also needed by dev-go/lfshook
- dev-go/zglob ( github.com/mattn/go-zglob )

dev-go/lfshook ( github.com/rifflock/lfshook )
- dev-go/logrus ( github.com/sirupsen/logrus )

dev-go/logrus
- dev-go/go-sys ( golang.org/x/sys )
- dev-go/go-windows-terminal-sequences
( github.com/konsorten/go-windows-terminal-sequences )
- dev-go/testify ( github.com/stretchr/testify )
*also needed by dev-go/objx

dev-go/testify ( github.com/stretchr/testify )
- >=dev-go/go-spew-1.1.0 ( github.com/davecgh/go-spew )
*also needed by dev-go/objx
- dev-go/go-difflib ( github.com/pmezard/go-difflib )
*also needed by dev-go/objx
- dev-go/objx ( github.com/stretchr/objx )

dev-go/objx ( github.com/stretchr/objx )
- dev-go/go-spew ( github.com/davecgh/go-spew ) *RDEPEND
- dev-go/go-difflib ( github.com/pmezard/go-difflib ) *RDEPEND
- dev-go/testify ( github.com/stretchr/testify ) *PDEPEND

08 Apr 2019; wjn <wjn@aol.jp> -browserpass-1.0.6.ebuild:
Delete old version 1.0.6

In the Firefox Add-ons and the Chrome Web Store,
there isn't old version extension (not "browserpass-ce") any longer
This version is already unusable

02 Jan 2019; wjn <wjn@aol.jp> browserpass-1.0.6.ebuild,
browserpass-2.0.21.ebuild:
Update the year of copyright notices to 2019

12 Nov 2018; wjn <wjn@aol.jp> browserpass-1.0.6.ebuild,
browserpass-2.0.21.ebuild:
[QA] Change copyright notices from 'Gentoo Foundation' to 'Gentoo Authors'

See GLEP 76
https://www.gentoo.org/glep/glep-0076.html

*browserpass-2.0.21 (20 Apr 2018)

20 Apr 2018; wjn <wjn@aol.jp> -browserpass-2.0.20.ebuild,
+browserpass-2.0.21.ebuild:
Add version 2.0.21, delete old version 2.0.20

*browserpass-2.0.20 (17 Apr 2018)

17 Apr 2018; wjn <wjn@aol.jp> -browserpass-2.0.18.ebuild,
+browserpass-2.0.20.ebuild:
Add version 2.0.20, delete old version 2.0.18

Upstream: https://github.com/browserpass/browserpass/releases/tag/2.0.20

*browserpass-2.0.18 (30 Mar 2018)

30 Mar 2018; wjn <wjn@aol.jp> -browserpass-2.0.17.ebuild,
+browserpass-2.0.18.ebuild:
Add version 2.0.18, delete old version 2.0.17

*browserpass-2.0.17 (25 Mar 2018)

25 Mar 2018; wjn <wjn@aol.jp> -browserpass-2.0.13.ebuild,
+browserpass-2.0.17.ebuild:
Add version 2.0.17, delete old 2.0.13

*browserpass-2.0.13 (19 Mar 2018)

19 Mar 2018; wjn <wjn@aol.jp> +browserpass-2.0.13.ebuild:
Add version 2.0.13 temporarily

Since Browserpass 2.0.12, compatibility breaks with older versions.
So newer browser extensions need newer host application

This commit is for use with newer browser extensions

12 Feb 2018; wjn <wjn@aol.jp> browserpass-1.0.6.ebuild:
Block www-plugins/browserpass-bin

07 Feb 2018; wjn <wjn@aol.jp> -browserpass-2.0.6.ebuild,
-browserpass-2.0.8.ebuild:
Delete version 2 series, use gentoo repository

www-plugins/browserpass-2.0.11 is added into the gentoo repository,
use that one for version 2 series

*browserpass-2.0.8 (07 Feb 2018)
*browserpass-2.0.6 (07 Feb 2018)
*browserpass-1.0.6 (07 Feb 2018)

07 Feb 2018; wjn <wjn@aol.jp> +browserpass-1.0.6.ebuild,
+browserpass-2.0.6.ebuild, +browserpass-2.0.8.ebuild, +metadata.xml:
app-admin/browserpass: Move to www-plugins/browserpass

Because browserpass is added to www-plugins category of the gentoo
repository