gpo.zugaina.org

Search Portage & Overlays:

dev-db/mycli

CLI for MySQL Database with auto-completion and syntax highlighting

Screenshots

  • mycli-9999
    ssh test test python_single_target_python3_6 python_single_target_python3_7 python_single_target_python3_8

    View      Download      Browse     License: BSD MIT   
    Overlay: gentoo (distro)
  • mycli-9999
    ssh test test python_single_target_python3_6 python_single_target_python3_7 python_single_target_python3_8 python_single_target_python3_9

    View      Download      Browse     License: BSD MIT   
    Overlay: mva (layman)
  • mycli-1.22.2_p20201026
    ~amd64 ~x86
    ssh test test python_single_target_python3_6 python_single_target_python3_7 python_single_target_python3_8

    View      Download      Browse     License: BSD MIT   
    Overlay: gentoo (distro)

Runtime Dependencies

mycli-9999


python_single_target_python3_6?
      ( >=dev-python/cli_helpers-2.0.1[python_targets_python3_6
            (-)
      ] >=dev-python/click-7.0[python_targets_python3_6
            (-)
      ] >=dev-python/configobj-5.0.6[python_targets_python3_6
            (-)
      ] >=dev-python/cryptography-1.0.0[python_targets_python3_6
            (-)
      ] >=dev-python/prompt_toolkit-3.0.0[python_targets_python3_6
            (-)
      ] <dev-python/prompt_toolkit-4.0.0[python_targets_python3_6
            (-)
      ] >=dev-python/pygments-2.0[python_targets_python3_6
            (-)
      ] >=dev-python/pymysql-0.9.2[python_targets_python3_6
            (-)
      ] >=dev-python/sqlparse-0.3.0[python_targets_python3_6
            (-)
      ] <dev-python/sqlparse-0.5.0[python_targets_python3_6
            (-)
      ] ssh?
            ( dev-python/paramiko[python_targets_python3_6
                  (-)
            ] )
       )

python_single_target_python3_7?
      ( >=dev-python/cli_helpers-2.0.1[python_targets_python3_7
            (-)
      ] >=dev-python/click-7.0[python_targets_python3_7
            (-)
      ] >=dev-python/configobj-5.0.6[python_targets_python3_7
            (-)
      ] >=dev-python/cryptography-1.0.0[python_targets_python3_7
            (-)
      ] >=dev-python/prompt_toolkit-3.0.0[python_targets_python3_7
            (-)
      ] <dev-python/prompt_toolkit-4.0.0[python_targets_python3_7
            (-)
      ] >=dev-python/pygments-2.0[python_targets_python3_7
            (-)
      ] >=dev-python/pymysql-0.9.2[python_targets_python3_7
            (-)
      ] >=dev-python/sqlparse-0.3.0[python_targets_python3_7
            (-)
      ] <dev-python/sqlparse-0.5.0[python_targets_python3_7
            (-)
      ] ssh?
            ( dev-python/paramiko[python_targets_python3_7
                  (-)
            ] )
       )

python_single_target_python3_8?
      ( >=dev-python/cli_helpers-2.0.1[python_targets_python3_8
            (-)
      ] >=dev-python/click-7.0[python_targets_python3_8
            (-)
      ] >=dev-python/configobj-5.0.6[python_targets_python3_8
            (-)
      ] >=dev-python/cryptography-1.0.0[python_targets_python3_8
            (-)
      ] >=dev-python/prompt_toolkit-3.0.0[python_targets_python3_8
            (-)
      ] <dev-python/prompt_toolkit-4.0.0[python_targets_python3_8
            (-)
      ] >=dev-python/pygments-2.0[python_targets_python3_8
            (-)
      ] >=dev-python/pymysql-0.9.2[python_targets_python3_8
            (-)
      ] >=dev-python/sqlparse-0.3.0[python_targets_python3_8
            (-)
      ] <dev-python/sqlparse-0.5.0[python_targets_python3_8
            (-)
      ] ssh?
            ( dev-python/paramiko[python_targets_python3_8
                  (-)
            ] )
       )

python_single_target_python3_6?
      ( dev-lang/python:3.6 >=dev-lang/python-exec-2:=[python_targets_python3_6] )

python_single_target_python3_7?
      ( dev-lang/python:3.7 >=dev-lang/python-exec-2:=[python_targets_python3_7] )

python_single_target_python3_8?
      ( dev-lang/python:3.8 >=dev-lang/python-exec-2:=[python_targets_python3_8] )

python_single_target_python3_6?
      ( >=dev-python/setuptools-42.0.2[python_targets_python3_6
            (-)
      ] )

python_single_target_python3_7?
      ( >=dev-python/setuptools-42.0.2[python_targets_python3_7
            (-)
      ] )

python_single_target_python3_8?
      ( >=dev-python/setuptools-42.0.2[python_targets_python3_8
            (-)
      ] )

mycli-9999


python_single_target_python3_6?
      ( >=dev-python/cli_helpers-1.1.0[python_targets_python3_6
            (-)
      ] >=dev-python/click-7.0[python_targets_python3_6
            (-)
      ] >=dev-python/configobj-5.0.6[python_targets_python3_6
            (-)
      ] >=dev-python/cryptography-1.0.0[python_targets_python3_6
            (-)
      ] >=dev-python/prompt_toolkit-3.0.0[python_targets_python3_6
            (-)
      ] <dev-python/prompt_toolkit-4.0.0[python_targets_python3_6
            (-)
      ] >=dev-python/pygments-2.0[python_targets_python3_6
            (-)
      ] >=dev-python/pymysql-0.9.2[python_targets_python3_6
            (-)
      ] >=dev-python/sqlparse-0.3.0[python_targets_python3_6
            (-)
      ] <dev-python/sqlparse-0.4.0[python_targets_python3_6
            (-)
      ] ssh?
            ( dev-python/paramiko[python_targets_python3_6
                  (-)
            ] )
       )

python_single_target_python3_7?
      ( >=dev-python/cli_helpers-1.1.0[python_targets_python3_7
            (-)
      ] >=dev-python/click-7.0[python_targets_python3_7
            (-)
      ] >=dev-python/configobj-5.0.6[python_targets_python3_7
            (-)
      ] >=dev-python/cryptography-1.0.0[python_targets_python3_7
            (-)
      ] >=dev-python/prompt_toolkit-3.0.0[python_targets_python3_7
            (-)
      ] <dev-python/prompt_toolkit-4.0.0[python_targets_python3_7
            (-)
      ] >=dev-python/pygments-2.0[python_targets_python3_7
            (-)
      ] >=dev-python/pymysql-0.9.2[python_targets_python3_7
            (-)
      ] >=dev-python/sqlparse-0.3.0[python_targets_python3_7
            (-)
      ] <dev-python/sqlparse-0.4.0[python_targets_python3_7
            (-)
      ] ssh?
            ( dev-python/paramiko[python_targets_python3_7
                  (-)
            ] )
       )

python_single_target_python3_8?
      ( >=dev-python/cli_helpers-1.1.0[python_targets_python3_8
            (-)
      ] >=dev-python/click-7.0[python_targets_python3_8
            (-)
      ] >=dev-python/configobj-5.0.6[python_targets_python3_8
            (-)
      ] >=dev-python/cryptography-1.0.0[python_targets_python3_8
            (-)
      ] >=dev-python/prompt_toolkit-3.0.0[python_targets_python3_8
            (-)
      ] <dev-python/prompt_toolkit-4.0.0[python_targets_python3_8
            (-)
      ] >=dev-python/pygments-2.0[python_targets_python3_8
            (-)
      ] >=dev-python/pymysql-0.9.2[python_targets_python3_8
            (-)
      ] >=dev-python/sqlparse-0.3.0[python_targets_python3_8
            (-)
      ] <dev-python/sqlparse-0.4.0[python_targets_python3_8
            (-)
      ] ssh?
            ( dev-python/paramiko[python_targets_python3_8
                  (-)
            ] )
       )

python_single_target_python3_9?
      ( >=dev-python/cli_helpers-1.1.0[python_targets_python3_9
            (-)
      ] >=dev-python/click-7.0[python_targets_python3_9
            (-)
      ] >=dev-python/configobj-5.0.6[python_targets_python3_9
            (-)
      ] >=dev-python/cryptography-1.0.0[python_targets_python3_9
            (-)
      ] >=dev-python/prompt_toolkit-3.0.0[python_targets_python3_9
            (-)
      ] <dev-python/prompt_toolkit-4.0.0[python_targets_python3_9
            (-)
      ] >=dev-python/pygments-2.0[python_targets_python3_9
            (-)
      ] >=dev-python/pymysql-0.9.2[python_targets_python3_9
            (-)
      ] >=dev-python/sqlparse-0.3.0[python_targets_python3_9
            (-)
      ] <dev-python/sqlparse-0.4.0[python_targets_python3_9
            (-)
      ] ssh?
            ( dev-python/paramiko[python_targets_python3_9
                  (-)
            ] )
       )

python_single_target_python3_6?
      ( dev-lang/python:3.6 >=dev-lang/python-exec-2:=[python_targets_python3_6] )

python_single_target_python3_7?
      ( dev-lang/python:3.7 >=dev-lang/python-exec-2:=[python_targets_python3_7] )

python_single_target_python3_8?
      ( dev-lang/python:3.8 >=dev-lang/python-exec-2:=[python_targets_python3_8] )

python_single_target_python3_9?
      ( dev-lang/python:3.9 >=dev-lang/python-exec-2:=[python_targets_python3_9] )

python_single_target_python3_6?
      ( >=dev-python/setuptools-42.0.2[python_targets_python3_6
            (-)
      ] )

python_single_target_python3_7?
      ( >=dev-python/setuptools-42.0.2[python_targets_python3_7
            (-)
      ] )

python_single_target_python3_8?
      ( >=dev-python/setuptools-42.0.2[python_targets_python3_8
            (-)
      ] )

python_single_target_python3_9?
      ( >=dev-python/setuptools-42.0.2[python_targets_python3_9
            (-)
      ] )

mycli-1.22.2_p20201026


python_single_target_python3_6?
      ( >=dev-python/cli_helpers-2.0.1[python_targets_python3_6
            (-)
      ] >=dev-python/click-7.0[python_targets_python3_6
            (-)
      ] >=dev-python/configobj-5.0.6[python_targets_python3_6
            (-)
      ] >=dev-python/cryptography-1.0.0[python_targets_python3_6
            (-)
      ] >=dev-python/prompt_toolkit-3.0.0[python_targets_python3_6
            (-)
      ] <dev-python/prompt_toolkit-4.0.0[python_targets_python3_6
            (-)
      ] >=dev-python/pygments-2.0[python_targets_python3_6
            (-)
      ] >=dev-python/pymysql-0.9.2[python_targets_python3_6
            (-)
      ] >=dev-python/sqlparse-0.3.0[python_targets_python3_6
            (-)
      ] <dev-python/sqlparse-0.5.0[python_targets_python3_6
            (-)
      ] ssh?
            ( dev-python/paramiko[python_targets_python3_6
                  (-)
            ] )
       )

python_single_target_python3_7?
      ( >=dev-python/cli_helpers-2.0.1[python_targets_python3_7
            (-)
      ] >=dev-python/click-7.0[python_targets_python3_7
            (-)
      ] >=dev-python/configobj-5.0.6[python_targets_python3_7
            (-)
      ] >=dev-python/cryptography-1.0.0[python_targets_python3_7
            (-)
      ] >=dev-python/prompt_toolkit-3.0.0[python_targets_python3_7
            (-)
      ] <dev-python/prompt_toolkit-4.0.0[python_targets_python3_7
            (-)
      ] >=dev-python/pygments-2.0[python_targets_python3_7
            (-)
      ] >=dev-python/pymysql-0.9.2[python_targets_python3_7
            (-)
      ] >=dev-python/sqlparse-0.3.0[python_targets_python3_7
            (-)
      ] <dev-python/sqlparse-0.5.0[python_targets_python3_7
            (-)
      ] ssh?
            ( dev-python/paramiko[python_targets_python3_7
                  (-)
            ] )
       )

python_single_target_python3_8?
      ( >=dev-python/cli_helpers-2.0.1[python_targets_python3_8
            (-)
      ] >=dev-python/click-7.0[python_targets_python3_8
            (-)
      ] >=dev-python/configobj-5.0.6[python_targets_python3_8
            (-)
      ] >=dev-python/cryptography-1.0.0[python_targets_python3_8
            (-)
      ] >=dev-python/prompt_toolkit-3.0.0[python_targets_python3_8
            (-)
      ] <dev-python/prompt_toolkit-4.0.0[python_targets_python3_8
            (-)
      ] >=dev-python/pygments-2.0[python_targets_python3_8
            (-)
      ] >=dev-python/pymysql-0.9.2[python_targets_python3_8
            (-)
      ] >=dev-python/sqlparse-0.3.0[python_targets_python3_8
            (-)
      ] <dev-python/sqlparse-0.5.0[python_targets_python3_8
            (-)
      ] ssh?
            ( dev-python/paramiko[python_targets_python3_8
                  (-)
            ] )
       )

python_single_target_python3_6?
      ( dev-lang/python:3.6 >=dev-lang/python-exec-2:=[python_targets_python3_6] )

python_single_target_python3_7?
      ( dev-lang/python:3.7 >=dev-lang/python-exec-2:=[python_targets_python3_7] )

python_single_target_python3_8?
      ( dev-lang/python:3.8 >=dev-lang/python-exec-2:=[python_targets_python3_8] )

python_single_target_python3_6?
      ( >=dev-python/setuptools-42.0.2[python_targets_python3_6
            (-)
      ] )

python_single_target_python3_7?
      ( >=dev-python/setuptools-42.0.2[python_targets_python3_7
            (-)
      ] )

python_single_target_python3_8?
      ( >=dev-python/setuptools-42.0.2[python_targets_python3_8
            (-)
      ] )