gpo.zugaina.org

Search Portage & Overlays:

dev-qt/qtsql

SQL abstraction library for the Qt5 framework

Screenshots

  • qtsql-5.9999
    freetds mysql oci8 odbc postgres +sqlite debug test

    View      Download      Browse     License: || ( GPL-2 GPL-3 LGPL-3 ) FDL-1.3   
    Overlay: qt (layman)
  • qtsql-5.13.9999
    freetds mysql oci8 odbc postgres +sqlite debug test

    View      Download      Browse     License: || ( GPL-2 GPL-3 LGPL-3 ) FDL-1.3   
    Overlay: qt (layman)
  • qtsql-5.13.0_pre
    ~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd
    freetds mysql oci8 odbc postgres +sqlite debug test

    View      Download      Browse     License: || ( GPL-2 GPL-3 LGPL-3 ) FDL-1.3   
    Overlay: pg_overlay (layman)
  • qtsql-5.12.9999
    freetds mysql oci8 odbc postgres +sqlite debug test

    View      Download      Browse     License: || ( GPL-2 GPL-3 LGPL-3 ) FDL-1.3   
    Overlay: qt (layman)
  • qtsql-5.12.4-r1
    ~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd
    freetds mysql oci8 odbc postgres +sqlite debug test

    View      Download      Browse     License: || ( GPL-2 GPL-3 LGPL-3 ) FDL-1.3   
    Overlay: gentoo (distro)
  • qtsql-5.12.3
    amd64 arm arm64 ~hppa ppc ppc64 ~sparc x86 ~amd64-fbsd
    freetds mysql oci8 odbc postgres +sqlite debug test

    View      Download      Browse     License: || ( GPL-2 GPL-3 LGPL-3 ) FDL-1.3   
    Overlay: gentoo (distro)
  • qtsql-4.8.7-r1
    +exceptions +qt3support +sqlite -aqua -debug -freetds -mysql -oci8 -odbc -pch -postgres -abi_x86_32 abi_x86_64

    View      Download      Browse     License:   
    Overlay: tresorit (outside)
  • qtsql-4.8.7-r1
    alpha amd64 arm ~arm64 ~hppa ia64 ~mips ppc ppc64 sparc x86 ~amd64-fbsd ~x86-fbsd
    freetds mysql oci8 odbc postgres qt3support +sqlite abi_x86_32 abi_x86_64 abi_x86_x32 abi_mips_n32 abi_mips_n64 abi_mips_o32 abi_ppc_32 abi_ppc_64 abi_s390_32 abi_s390_64 aqua debug pch +exceptions

    View      Download      Browse     License: || ( LGPL-2.1 LGPL-3 GPL-3 ) FDL-1.3   
    Overlay: booboo (layman)

Runtime Dependencies

qtsql-5.9999

~dev-qt/qtcore-5.9999

freetds?
      ( dev-db/freetds )

mysql?
      ( dev-db/mysql-connector-c:= )

oci8?
      ( dev-db/oracle-instantclient:=[sdk] )

odbc?
      ( dev-db/unixODBC )

postgres?
      ( dev-db/postgresql:* )

sqlite?
      ( dev-db/sqlite:3 )

dev-qt/qtchooser

qtsql-5.13.9999

~dev-qt/qtcore-5.13.9999

freetds?
      ( dev-db/freetds )

mysql?
      ( dev-db/mysql-connector-c:= )

oci8?
      ( dev-db/oracle-instantclient:=[sdk] )

odbc?
      ( dev-db/unixODBC )

postgres?
      ( dev-db/postgresql:* )

sqlite?
      ( dev-db/sqlite:3 )

dev-qt/qtchooser

qtsql-5.13.0_pre

~dev-qt/qtcore-5.13.0_pre

freetds?
      ( dev-db/freetds )

mysql?
      ( dev-db/mysql-connector-c:= )

oci8?
      ( dev-db/oracle-instantclient:=[sdk] )

odbc?
      ( dev-db/unixODBC )

postgres?
      ( dev-db/postgresql:* )

sqlite?
      ( dev-db/sqlite:3 )

dev-qt/qtchooser

qtsql-5.12.9999

~dev-qt/qtcore-5.12.9999

freetds?
      ( dev-db/freetds )

mysql?
      ( dev-db/mysql-connector-c:= )

oci8?
      ( dev-db/oracle-instantclient:=[sdk] )

odbc?
      ( dev-db/unixODBC )

postgres?
      ( dev-db/postgresql:* )

sqlite?
      ( dev-db/sqlite:3 )

dev-qt/qtchooser

qtsql-5.12.4-r1

~dev-qt/qtcore-5.12.4

freetds?
      ( dev-db/freetds )

mysql?
      ( dev-db/mysql-connector-c:= )

oci8?
      ( dev-db/oracle-instantclient:=[sdk] )

odbc?
      ( dev-db/unixODBC )

postgres?
      ( dev-db/postgresql:* )

sqlite?
      ( dev-db/sqlite:3 )

dev-qt/qtchooser

qtsql-5.12.3

~dev-qt/qtcore-5.12.3

freetds?
      ( dev-db/freetds )

mysql?
      ( dev-db/mysql-connector-c:= )

oci8?
      ( dev-db/oracle-instantclient:=[sdk] )

odbc?
      ( dev-db/unixODBC )

postgres?
      ( dev-db/postgresql:* )

sqlite?
      ( dev-db/sqlite:3 )

dev-qt/qtchooser

qtsql-4.8.7-r1

qtsql-4.8.7-r1











~dev-qt/qtcore-4.8.7[aqua=,debug=,qt3support=,abi_x86_32
      (-)
?
,abi_x86_64
      (-)
?
,abi_x86_x32
      (-)
?
,abi_mips_n32
      (-)
?
,abi_mips_n64
      (-)
?
,abi_mips_o32
      (-)
?
,abi_ppc_32
      (-)
?
,abi_ppc_64
      (-)
?
,abi_s390_32
      (-)
?
,abi_s390_64
      (-)
?
]

freetds?
      ( dev-db/freetds )

mysql?
      ( virtual/libmysqlclient:=[abi_x86_32
            (-)
      ?
,abi_x86_64
            (-)
      ?
,abi_x86_x32
            (-)
      ?
,abi_mips_n32
            (-)
      ?
,abi_mips_n64
            (-)
      ?
,abi_mips_o32
            (-)
      ?
,abi_ppc_32
            (-)
      ?
,abi_ppc_64
            (-)
      ?
,abi_s390_32
            (-)
      ?
,abi_s390_64
            (-)
      ?
] )

oci8?
      ( >=dev-db/oracle-instantclient-basic-11.2.0.4[abi_x86_32
            (-)
      ?
,abi_x86_64
            (-)
      ?
,abi_x86_x32
            (-)
      ?
,abi_mips_n32
            (-)
      ?
,abi_mips_n64
            (-)
      ?
,abi_mips_o32
            (-)
      ?
,abi_ppc_32
            (-)
      ?
,abi_ppc_64
            (-)
      ?
,abi_s390_32
            (-)
      ?
,abi_s390_64
            (-)
      ?
] )

odbc?
      ( ||
            ( >=dev-db/unixODBC-2.3.2-r2[abi_x86_32
                  (-)
            ?
,abi_x86_64
                  (-)
            ?
,abi_x86_x32
                  (-)
            ?
,abi_mips_n32
                  (-)
            ?
,abi_mips_n64
                  (-)
            ?
,abi_mips_o32
                  (-)
            ?
,abi_ppc_32
                  (-)
            ?
,abi_ppc_64
                  (-)
            ?
,abi_s390_32
                  (-)
            ?
,abi_s390_64
                  (-)
            ?
] >=dev-db/libiodbc-3.52.8-r2[abi_x86_32
                  (-)
            ?
,abi_x86_64
                  (-)
            ?
,abi_x86_x32
                  (-)
            ?
,abi_mips_n32
                  (-)
            ?
,abi_mips_n64
                  (-)
            ?
,abi_mips_o32
                  (-)
            ?
,abi_ppc_32
                  (-)
            ?
,abi_ppc_64
                  (-)
            ?
,abi_s390_32
                  (-)
            ?
,abi_s390_64
                  (-)
            ?
] )
       )

postgres?
      ( dev-db/postgresql:* )

sqlite?
      ( >=dev-db/sqlite-3.8.3:3[abi_x86_32
            (-)
      ?
,abi_x86_64
            (-)
      ?
,abi_x86_x32
            (-)
      ?
,abi_mips_n32
            (-)
      ?
,abi_mips_n64
            (-)
      ?
,abi_mips_o32
            (-)
      ?
,abi_ppc_32
            (-)
      ?
,abi_ppc_64
            (-)
      ?
,abi_s390_32
            (-)
      ?
,abi_s390_64
            (-)
      ?
] )

dev-qt/qtchooser